import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*\\/).*";
final String string = "# Remove file name from path\n"
+ "# I just want to keep the directory the file is in\n\n"
+ "../data/detect_5wk.csv\n"
+ "../data/detect_5wk.nb.html\n\n"
+ "# This means that I will have to do a substitution in R\n"
+ "# stringr::str_replace(\"../data/detect_5wk.csv\", \"(.*\\\\/).*\", \"\\\\1\")";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}