$re = '/(.*\/).*/m';
$str = '# Remove file name from path
# I just want to keep the directory the file is in
../data/detect_5wk.csv
../data/detect_5wk.nb.html
# This means that I will have to do a substitution in R
# stringr::str_replace("../data/detect_5wk.csv", "(.*\\\\/).*", "\\\\1")';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;