package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*\/).*`)
var str = `# Remove file name from path
# I just want to keep the directory the file is in
../data/detect_5wk.csv
../data/detect_5wk.nb.html
# This means that I will have to do a substitution in R
# stringr::str_replace("../data/detect_5wk.csv", "(.*\\/).*", "\\1")`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}