# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*\\/).*/\1/gm;t' <<< "# Remove file name from path
# I just want to keep the directory the file is in
../data/detect_5wk.csv
../data/detect_5wk.nb.html
# This means that I will have to do a substitution in R
# stringr::str_replace(\"../data/detect_5wk.csv\", \"(.*\\/).*\", \"\\1\")"