#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*\/).*"
Local $sString = "# Remove file name from path" & @CRLF & _
"# I just want to keep the directory the file is in" & @CRLF & _
"" & @CRLF & _
"../data/detect_5wk.csv" & @CRLF & _
"../data/detect_5wk.nb.html" & @CRLF & _
"" & @CRLF & _
"# This means that I will have to do a substitution in R" & @CRLF & _
"# stringr::str_replace("../data/detect_5wk.csv", "(.*\\/).*", "\\1")"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)