// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d\d\d\d) (\w\w\w\w\w\w\w\w\w)(\s)(\w\w)").unwrap();
let string = "1972 31JUL1972 _1
\"_\" is een word character, \"-\" is dit niet";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}