package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d\d\d\d) (\w\w\w\w\w\w\w\w\w)(\s)(\w\w)`)
var str = `1972 31JUL1972 _1
"_" is een word character, "-" is dit niet`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}