$re = '/(\d\d\d\d) (\w\w\w\w\w\w\w\w\w)(\s)(\w\w)/m';
$str = '1972 31JUL1972 _1
"_" is een word character, "-" is dit niet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);