using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d\d\d\d) (\w\w\w\w\w\w\w\w\w)(\s)(\w\w)";
string input = @"1972 31JUL1972 _1
""_"" is een word character, ""-"" is dit niet";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}