const regex = /(\d\d\d\d) (\w\w\w\w\w\w\w\w\w)(\s)(\w\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d\\d\\d\\d) (\\w\\w\\w\\w\\w\\w\\w\\w\\w)(\\s)(\\w\\w)', 'gm')
const str = `1972 31JUL1972 _1
"_" is een word character, "-" is dit niet`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}