import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d\\d\\d\\d) (\\w\\w\\w\\w\\w\\w\\w\\w\\w)(\\s)(\\w\\w)";
final String string = "1972 31JUL1972 _1\n"
+ "\"_\" is een word character, \"-\" is dit niet";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}