re = /(\d\d\d\d) (\w\w\w\w\w\w\w\w\w)(\s)(\w\w)/m
str = '1972 31JUL1972 _1
"_" is een word character, "-" is dit niet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end