// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+[\d\*]{11,13}$").unwrap();
let string = "Cas passants :
+3362788****
+337**0140**
+336********
+491**********
+3362788******
+491**27880140
+49106**88**40
+32*********
Cas non passants :
+3362788*******
+49 1** *** ** **
062788****
+33627*****
+33627**014
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}