using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+[\d\*]{11,13}$";
string input = @"Cas passants :
+3362788****
+337**0140**
+336********
+491**********
+3362788******
+491**27880140
+49106**88**40
+32*********
Cas non passants :
+3362788*******
+49 1** *** ** **
062788****
+33627*****
+33627**014
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}