use strict;
my $str = 'Cas passants :
+3362788****
+337**0140**
+336********
+491**********
+3362788******
+491**27880140
+49106**88**40
+32*********
Cas non passants :
+3362788*******
+49 1** *** ** **
062788****
+33627*****
+33627**014
';
my $regex = qr/^\+[\d\*]{11,13}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}