#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+[\d\*]{11,13}$"
Local $sString = "Cas passants :" & @CRLF & _
"+3362788****" & @CRLF & _
"+337**0140**" & @CRLF & _
"+336********" & @CRLF & _
"+491**********" & @CRLF & _
"+3362788******" & @CRLF & _
"+491**27880140" & @CRLF & _
"+49106**88**40" & @CRLF & _
"+32*********" & @CRLF & _
"" & @CRLF & _
"Cas non passants :" & @CRLF & _
"+3362788*******" & @CRLF & _
"+49 1** *** ** **" & @CRLF & _
"062788****" & @CRLF & _
"+33627*****" & @CRLF & _
"+33627**014" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")