$re = '/^\+[\d\*]{11,13}$/m';
$str = 'Cas passants :
+3362788****
+337**0140**
+336********
+491**********
+3362788******
+491**27880140
+49106**88**40
+32*********
Cas non passants :
+3362788*******
+49 1** *** ** **
062788****
+33627*****
+33627**014
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);