package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+[\d\*]{11,13}$`)
var str = `Cas passants :
+3362788****
+337**0140**
+336********
+491**********
+3362788******
+491**27880140
+49106**88**40
+32*********
Cas non passants :
+3362788*******
+49 1** *** ** **
062788****
+33627*****
+33627**014
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}