import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+[\\d\\*]{11,13}$";
final String string = "Cas passants :\n"
+ "+3362788****\n"
+ "+337**0140**\n"
+ "+336********\n"
+ "+491**********\n"
+ "+3362788******\n"
+ "+491**27880140\n"
+ "+49106**88**40\n"
+ "+32*********\n\n"
+ "Cas non passants :\n"
+ "+3362788*******\n"
+ "+49 1** *** ** **\n"
+ "062788****\n"
+ "+33627*****\n"
+ "+33627**014\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}