re = /(\pL+)(\d+)/m
str = 'Форд23324
Форд23325
Форд23326
Форд23327
Форд23328
Форд23329
Форд23330
Форд23331
Форд23332
Форд23333
Форд23334
Форд23335
Форд23336
'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result