#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\pL+)(\d+)"
Local $sString = "Форд23324" & @CRLF & _
"Форд23325" & @CRLF & _
"Форд23326" & @CRLF & _
"Форд23327" & @CRLF & _
"Форд23328" & @CRLF & _
"Форд23329" & @CRLF & _
"Форд23330" & @CRLF & _
"Форд23331" & @CRLF & _
"Форд23332" & @CRLF & _
"Форд23333" & @CRLF & _
"Форд23334" & @CRLF & _
"Форд23335" & @CRLF & _
"Форд23336" & @CRLF & _
""
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)