# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\pL+)(\d+)/$1 $2/gm;t' <<< "Форд23324
Форд23325
Форд23326
Форд23327
Форд23328
Форд23329
Форд23330
Форд23331
Форд23332
Форд23333
Форд23334
Форд23335
Форд23336
"