using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\pL+)(\d+)";
string substitution = @"$1 $2";
string input = @"Форд23324
Форд23325
Форд23326
Форд23327
Форд23328
Форд23329
Форд23330
Форд23331
Форд23332
Форд23333
Форд23334
Форд23335
Форд23336
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}