const regex = /(\pL+)(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\pL+)(\\d+)', 'gm')
const str = `Форд23324
Форд23325
Форд23326
Форд23327
Форд23328
Форд23329
Форд23330
Форд23331
Форд23332
Форд23333
Форд23334
Форд23335
Форд23336
`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);