// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^R\$ )?(\d+(\.)?)+(\,\d{1,2})?$").unwrap();
let string = "R$ 1.000,00
R$ 1.000.000,00
1.000,00
1000,00
1000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}