$re = '/(^R\$ )?(\d+(\.)?)+(\,\d{1,2})?$/m';
$str = 'R$ 1.000,00
R$ 1.000.000,00
1.000,00
1000,00
1000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);