re = /(^R\$ )?(\d+(\.)?)+(\,\d{1,2})?$/m
str = 'R$ 1.000,00
R$ 1.000.000,00
1.000,00
1000,00
1000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end