import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^R\\$ )?(\\d+(\\.)?)+(\\,\\d{1,2})?$";
final String string = "R$ 1.000,00\n"
+ "R$ 1.000.000,00\n"
+ "1.000,00\n"
+ "1000,00\n"
+ "1000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}