package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^R\$ )?(\d+(\.)?)+(\,\d{1,2})?$`)
var str = `R$ 1.000,00
R$ 1.000.000,00
1.000,00
1000,00
1000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}