#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^R\$ )?(\d+(\.)?)+(\,\d{1,2})?$"
Local $sString = "R$ 1.000,00" & @CRLF & _
"R$ 1.000.000,00" & @CRLF & _
"1.000,00" & @CRLF & _
"1000,00" & @CRLF & _
"1000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")