using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^R\$ )?(\d+(\.)?)+(\,\d{1,2})?$";
string input = @"R$ 1.000,00
R$ 1.000.000,00
1.000,00
1000,00
1000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}