import Foundation
let pattern = #"\+?(\d{1,2})?[ .-]?\(?(\d{3})\)?[ .-]?(\d{3})[ .-]?(\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+1 (810) 273-7759
1 810 273 7759
18102737759
(725) 549-2268
(835) 471-7653
(259) 424-8880
(842) 818-7651
(388) 340-1005
(327) 696-4067
(639) 815-1491
(617) 289-5904
+1-202-555-0161
+1-202-555-0170
+1-202-555-0162
+1-202-555-0190
+1-202-555-0109
+1-202-555-0117
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)