#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\+?(\d{1,2})?[ .-]?\(?(\d{3})\)?[ .-]?(\d{3})[ .-]?(\d{4})"
Local $sString = "+1 (810) 273-7759" & @CRLF & _
"1 810 273 7759" & @CRLF & _
"18102737759" & @CRLF & _
"(725) 549-2268" & @CRLF & _
"(835) 471-7653" & @CRLF & _
"(259) 424-8880" & @CRLF & _
"(842) 818-7651" & @CRLF & _
"(388) 340-1005" & @CRLF & _
"(327) 696-4067" & @CRLF & _
"(639) 815-1491" & @CRLF & _
"(617) 289-5904" & @CRLF & _
"+1-202-555-0161" & @CRLF & _
"+1-202-555-0170" & @CRLF & _
"+1-202-555-0162" & @CRLF & _
"+1-202-555-0190" & @CRLF & _
"+1-202-555-0109" & @CRLF & _
"+1-202-555-0117"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")