package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+?(\d{1,2})?[ .-]?\(?(\d{3})\)?[ .-]?(\d{3})[ .-]?(\d{4})`)
var str = `+1 (810) 273-7759
1 810 273 7759
18102737759
(725) 549-2268
(835) 471-7653
(259) 424-8880
(842) 818-7651
(388) 340-1005
(327) 696-4067
(639) 815-1491
(617) 289-5904
+1-202-555-0161
+1-202-555-0170
+1-202-555-0162
+1-202-555-0190
+1-202-555-0109
+1-202-555-0117`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}