use strict;
my $str = '+1 (810) 273-7759
1 810 273 7759
18102737759
(725) 549-2268
(835) 471-7653
(259) 424-8880
(842) 818-7651
(388) 340-1005
(327) 696-4067
(639) 815-1491
(617) 289-5904
+1-202-555-0161
+1-202-555-0170
+1-202-555-0162
+1-202-555-0190
+1-202-555-0109
+1-202-555-0117';
my $regex = qr/\+?(\d{1,2})?[ .-]?\(?(\d{3})\)?[ .-]?(\d{3})[ .-]?(\d{4})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}