import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+?(\\d{1,2})?[ .-]?\\(?(\\d{3})\\)?[ .-]?(\\d{3})[ .-]?(\\d{4})";
final String string = "+1 (810) 273-7759\n"
+ "1 810 273 7759\n"
+ "18102737759\n"
+ "(725) 549-2268\n"
+ "(835) 471-7653\n"
+ "(259) 424-8880\n"
+ "(842) 818-7651\n"
+ "(388) 340-1005\n"
+ "(327) 696-4067\n"
+ "(639) 815-1491\n"
+ "(617) 289-5904\n"
+ "+1-202-555-0161\n"
+ "+1-202-555-0170\n"
+ "+1-202-555-0162\n"
+ "+1-202-555-0190\n"
+ "+1-202-555-0109\n"
+ "+1-202-555-0117";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}