$re = '/\+?(\d{1,2})?[ .-]?\(?(\d{3})\)?[ .-]?(\d{3})[ .-]?(\d{4})/m';
$str = '+1 (810) 273-7759
1 810 273 7759
18102737759
(725) 549-2268
(835) 471-7653
(259) 424-8880
(842) 818-7651
(388) 340-1005
(327) 696-4067
(639) 815-1491
(617) 289-5904
+1-202-555-0161
+1-202-555-0170
+1-202-555-0162
+1-202-555-0190
+1-202-555-0109
+1-202-555-0117';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);