# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\+?(\d{1,2})?[ .-]?\(?(\d{3})\)?[ .-]?(\d{3})[ .-]?(\d{4})"
test_str = ("+1 (810) 273-7759\n"
"1 810 273 7759\n"
"18102737759\n"
"(725) 549-2268\n"
"(835) 471-7653\n"
"(259) 424-8880\n"
"(842) 818-7651\n"
"(388) 340-1005\n"
"(327) 696-4067\n"
"(639) 815-1491\n"
"(617) 289-5904\n"
"+1-202-555-0161\n"
"+1-202-555-0170\n"
"+1-202-555-0162\n"
"+1-202-555-0190\n"
"+1-202-555-0109\n"
"+1-202-555-0117")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.