import Foundation
let pattern = #"( 's| 'd)|[[:lower:]](\.|\!|\?) ?"?[[:lower:]]|(\w|"),"?\w|( |^)"?(i|"|'|,|\!|\?|\.)(\s|")|_|(“|”)|\|"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
| 12:30pm |
Jeff 's friend said he 'd let us know when it 's done. the next day he called."it's done.",he said,Obviously lying.
i was not happy with the result. " Do it again !" i just could _not_ believe how _bad_ it was .
“What's wong with it?”
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)