$re = '/( \'s| \'d)|[[:lower:]](\.|\!|\?) ?"?[[:lower:]]|(\w|"),"?\w|( |^)"?(i|"|\'|,|\!|\?|\.)(\s|")|_|(“|”)|\|/m';
$str = '| 12:30pm |
Jeff \'s friend said he \'d let us know when it \'s done. the next day he called."it\'s done.",he said,Obviously lying.
i was not happy with the result. " Do it again !" i just could _not_ believe how _bad_ it was .
“What\'s wong with it?”';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);