using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( 's| 'd)|[[:lower:]](\.|\!|\?) ?""?[[:lower:]]|(\w|""),""?\w|( |^)""?(i|""|'|,|\!|\?|\.)(\s|"")|_|(“|”)|\|";
string input = @"| 12:30pm |
Jeff 's friend said he 'd let us know when it 's done. the next day he called.""it's done."",he said,Obviously lying.
i was not happy with the result. "" Do it again !"" i just could _not_ believe how _bad_ it was .
“What's wong with it?”";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}