package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)( 's| 'd)|[[:lower:]](\.|\!|\?) ?"?[[:lower:]]|(\w|"),"?\w|( |^)"?(i|"|'|,|\!|\?|\.)(\s|")|_|(“|”)|\|`)
var str = `| 12:30pm |
Jeff 's friend said he 'd let us know when it 's done. the next day he called."it's done.",he said,Obviously lying.
i was not happy with the result. " Do it again !" i just could _not_ believe how _bad_ it was .
“What's wong with it?”`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}