import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( 's| 'd)|[[:lower:]](\\.|\\!|\\?) ?\"?[[:lower:]]|(\\w|\"),\"?\\w|( |^)\"?(i|\"|'|,|\\!|\\?|\\.)(\\s|\")|_|(“|”)|\\|";
final String string = "| 12:30pm |\n"
+ "Jeff 's friend said he 'd let us know when it 's done. the next day he called.\"it's done.\",he said,Obviously lying.\n"
+ "i was not happy with the result. \" Do it again !\" i just could _not_ believe how _bad_ it was .\n"
+ "“What's wong with it?”";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}