// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)( 's| 'd)|[[:lower:]](\.|\!|\?) ?"?[[:lower:]]|(\w|"),"?\w|( |^)"?(i|"|'|,|\!|\?|\.)(\s|")|_|(“|”)|\|"#).unwrap();
let string = "| 12:30pm |
Jeff 's friend said he 'd let us know when it 's done. the next day he called.\"it's done.\",he said,Obviously lying.
i was not happy with the result. \" Do it again !\" i just could _not_ believe how _bad_ it was .
“What's wong with it?”";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}