const regex = /( 's| 'd)|[[:lower:]](\.|\!|\?) ?"?[[:lower:]]|(\w|"),"?\w|( |^)"?(i|"|'|,|\!|\?|\.)(\s|")|_|(“|”)|\|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('( \'s| \'d)|[[:lower:]](\\.|\\!|\\?) ?"?[[:lower:]]|(\\w|"),"?\\w|( |^)"?(i|"|\'|,|\\!|\\?|\\.)(\\s|")|_|(“|”)|\\|', 'gm')
const str = `| 12:30pm |
Jeff 's friend said he 'd let us know when it 's done. the next day he called."it's done.",he said,Obviously lying.
i was not happy with the result. " Do it again !" i just could _not_ believe how _bad_ it was .
“What's wong with it?”`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}