// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9]{1}[0-9]?([\.]?[0-9]+|[0-9]*)[GT]{1}$").unwrap();
let string = "10.8G
5G
1.5G
15G
0
5
0.5
G
.G
.5G
1.G";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}