package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9]{1}[0-9]?([\.]?[0-9]+|[0-9]*)[GT]{1}$`)
var str = `10.8G
5G
1.5G
15G
0
5
0.5
G
.G
.5G
1.G`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}