use strict;
my $str = '10.8G
5G
1.5G
15G
0
5
0.5
G
.G
.5G
1.G';
my $regex = qr/^[1-9]{1}[0-9]?([\.]?[0-9]+|[0-9]*)[GT]{1}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}