using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9]{1}[0-9]?([\.]?[0-9]+|[0-9]*)[GT]{1}$";
string input = @"10.8G
5G
1.5G
15G
0
5
0.5
G
.G
.5G
1.G";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}