const regex = /^[1-9]{1}[0-9]?([\.]?[0-9]+|[0-9]*)[GT]{1}$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9]{1}[0-9]?([\\.]?[0-9]+|[0-9]*)[GT]{1}$', 'mg')
const str = `10.8G
5G
1.5G
15G
0
5
0.5
G
.G
.5G
1.G`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}